Kaavaa yötyötuntien laskemiseen

Seuraa 
Viestejä45973
Liittynyt3.9.2015

Kertokaahan viisaat minkälaisella kaavalla selviää tilanteesta, jossa pitäisi laskea työvuorojen yötunteja. Eli kun tiedetään työvuorojen alku- ja loppuajat, esim. 1.1.2009 kello 18 - 2.1.2009 kello 04. Näistä pitäisi selvittää, paljonko työajasta on yötunteja eli välillä 23 - 06. Esimerkkityövuorossa vastaus olisi siis 5 tuntia. Tällaiseen löytynee joku järkevä ja yleispätevä kaava?

Kommentit (12)

Vierailija

Riippuu paljolti siitäkin tarvitsetko asiaa johonkin tehtävään vai onko todellisesta työelämän ongelmasta kysymys.

Siihen olisi hyvä tietää mikä ala ja mikä työehtosopimus. Onko kyse jatkuvasta kolmivuorotyöstä vai onko kyse vuorotyöstä, jossa koko yötä ei aina vuoron aikana olla töissä

Jatkuvassa yövuorotyössä yövuoro on alasta riippuen klo 21/23 - 06/07 välisenä aikana tehtyä työtä. Silloin kolmasosa kaikista vuorokauden tunneista on yötyötä.

Asia kuitenkin vaihtelee aloittain ja sopimuksittain. Tuo antamasi aika viittaa esim. ravintolatyöhön ja siihen tuskin on mitään kaavaa annettavissa, koska siinä vuorot voivat loppua lähes mihin aikaan tahansa.

Ertsu
Seuraa 
Viestejä6541
Liittynyt8.11.2007

Ainakin metallissa yötyötunnit ovat klo. 22:00-06:00 välillä tehtyjä tunteja. Eipä siihen muuta kaavaa tarvita kuin yhteenlasku. Lasket yhteen k.o. aikavälillä tekemäsi tunnit. That's it.

Vierailija

Ei ole kyse tehtävästä vaan ihan oikeasta tilanteesta. Työehtosopimusta ei tarvitse ottaa huomioon sen enempää, tässä tapauksessa yötunneiksi lasketaan aina 23-06 välinen aika. Riittää siis kun selvitetään paljonko annetun alku- ja loppuajan välisestä ajasta osuu 23-06 välille.

Ja ihan niin simppeliähän se ei ole, "ettei mitään kaavaa tarvita, senkus laskee vaan". Kun eri työvuoroja on vaikkapa 5000kpl niin kyllä sen mieluusti kaavalla hoitaisi ohjelmallisesti.

Vierailija
tjaa
Ja ihan niin simppeliähän se ei ole, "ettei mitään kaavaa tarvita, senkus laskee vaan". Kun eri työvuoroja on vaikkapa 5000kpl niin kyllä sen mieluusti kaavalla hoitaisi ohjelmallisesti.



En oikein ymmärrä, millaista kaavaa haet?

Onko nuo sinulla esim. exellissä vai paperilla tai jossain ohjelmassa? Ja mitä aiot tuloksella tehdä? Tarvitsetko ne eriteltyinä/päivä(työvuoro) vai riittääkö summa/viikko tai miten?

Anna nyt hieman tarkemmat speksit, ei noilla voi muuta ohjetta oikein antaa kuin tuon Ertsun, senkus laskee vaan.

Vierailija

Työvuorot on SQL-kannassa. Sieltä haetaan yhden ihmisen yksittäinen työvuoro, josta saadaan kyseisen työvuoron alkuaika ja loppuaika. Sen jälkeen pitäisi selvittää moniko tunti tuon yksittäisen työajan alkuajan ja loppuajan välissä osuu aikavälille 23-06.

Esimerkki minkätyyppisestä kaavasta höpötän: eräässä toisessa tapauksessa laskettiin iltatunteja työvuoroista kaavalla (LOPPUAIKA - ALKUAIKA) - (18 - ALKUAIKA). Näin siis laskettiin paljonko työpäivästä oli kello 18 jälkeen. Eli jos esim. on menty töihin kello 8 ja lähdetty töistä kello 20: (20 - - (18 - = 12 - 10 = 2. Eli 2 tuntia iltatöitä. Tuo kaava ei päde kuin normaaleihin päivätyöaikoihin mutta siis esimerkkinä minkälaista ratkaisua kaipailen.

Vierailija

Toimiihan tuo edelleen

Loppuaika-alkuaika. Jos alkuaika > 23 JA loppuaika < 6, niin tunnit yötöitä.

Ehkä kannattaa jakaa noita tunteja yhteen vuorokauteen eli käsittelee 00.00 - 24.00 aikaa yhtenä ja jos tunnit menevät vuorokauden rajan yli katkaisee laskennan siinä kohtaa. Voi olla helpompi toteuttaa. Tulee samalla huomioitua sunnuntai ja arkityön ero.

Vierailija

Vaan esimerkiksi jos joku on ollut töissä yöllä 01 - 03, niin tuolla kaavalla (LOPPUAIKA - ALKUAIKA) - (18 - ALKUAIKA) päädyttäisiin tällaiseen:

(3 - 1) - (18 - 1) = 2 - 17 = -15

Mutta joo, lopputulos on siis se, että toteutan tuon tosiaan katkaisemalla työvuorot vuorokausirajoista ja siitä sitten käpistelen luvut ulos. Halusin vaan selvittää, että josko tähän olisi ollut joku näpsäkkä laskentatapa mitä en vain itse ole älynnyt.

Vierailija

Tuo 18 oli tuossa alkuperäisessä kaavassa ilmeisesti sen takia, että silloin alkaa iltatyötunnit.

Edit.
Eikä tuo sinun kaavasi muutenkaan toimi. Se kyllä antaa ne tunnit, jotka on tehty klo 18.00 jälkeen, mutta jos tunnit menevät yli 23, jolloin yötunnit alkavat, niin silloin se jo laskee pieleen. Esim. työvuoro alkaa klo 16.00 ja loppuu klo 24.00. Eipäs laskekaan iltatunteja oikein.

Mutta kuten Ertsu tuossa alla asian ilmaisee. Noin se menee.

Ertsu
Seuraa 
Viestejä6541
Liittynyt8.11.2007
tjaa
Vaan esimerkiksi jos joku on ollut töissä yöllä 01 - 03, niin tuolla kaavalla (LOPPUAIKA - ALKUAIKA) - (18 - ALKUAIKA) päädyttäisiin tällaiseen:

(3 - 1) - (18 - 1) = 2 - 17 = -15

Mutta joo, lopputulos on siis se, että toteutan tuon tosiaan katkaisemalla työvuorot vuorokausirajoista ja siitä sitten käpistelen luvut ulos. Halusin vaan selvittää, että josko tähän olisi ollut joku näpsäkkä laskentatapa mitä en vain itse ole älynnyt.


On siihen näpsäkkä laskemistapa. Jos joku on ollut töissä klo. 01-03, hän on ollut 2 tuntia. 3-1=2. Voi älyn väläys.

Vierailija

L = LOPPUAIKA
A = ALKUAIKA
JOS L<23 L = 23
JOS A>6 A = 6
YÖTUNNIT = L-A
Noissa ajoissa on vuorokauden vaihtuminen huomioitava eli jos ajat sisältävät myös päivämäärän se menee oikein. Muutoin ehkä parempi laskea vuorokauden sisällä tunnit kuten Phony ehdotti.

Vanha jäärä
Seuraa 
Viestejä1557
Liittynyt12.4.2005

Kokeilin laskentaa Excelillä ja siellä - tietyin rajoituksin - homman sai toimimaan.

Määritin ensin sarakkeille A ja B, joissa on vuoron alku- ja loppuajat, muotoilun Oma -> p.k.vvvv t:mm, esim. 1.1.2009 18:00. Sarakkeille C-E annoin muotoilun Luku. Sarakkeen F, eli yötyöaika, muotoilu taas on Oma -> t:mm.

Sitten otin käyttöön funktiot:
Sarakkeelle C: =JAKOJ(A1;1)
sarakkeelle D: =JOS(KATKAISE(A1)=KATKAISE(B1);JAKOJ(B1;1);JAKOJ(B1;1)+1)
sarakkeelle E: =MIN(D1;1,25)-MAKS(C1;23/24)
sarakkeelle F: =JOS(E1>0;E1;0).

Menettely näyttää toimivan, kun vuoron alku ei satu kellonaikojen 0-6 alueelle eikä ulotu yötyöajasta toiseen, eli esimerkiksi klo 1.1.2009 23:00 -> 3.1.2009 2:00.

Sarakkeet C-E ovat ainoastaan funktioiden toiminnan tarkistamista varten ja ne voidaan jättää pois, jolloin niiden funktiot on tietysti myös yhdistettävä yötyöaikasarakkeeseen.

Vanha jäärä

Uusimmat

Suosituimmat